2008-09-04

Apple Remote Desktop and the 3.889 Error

If you have Mac OS X 10.5, you can run "Screen Sharing" which is Apple's version of VNC. However, if you simply enable it and try to connect, you will get an error such as:

VNC server supports protocol version 3.889 (viewer 3.3)
VNC connection failed: Incompatible Version.

This will also appear as similar errors about incompatible security and so forth from various other VNC viewers; the above error is xtightvncviewer on Ubuntu Linux.

The cause of the problem is that Apple's Remote Desktop supports additional features in security that are not part of the normal VNC protocol; to fix it, click "Computer Settings" under Screen Sharing on the Sharing page of System Preferences, and set a password for VNC viewers. Then it will work.

1 comment:

Michel said...

Thanks to you i'm now able to crontol my mac :)